• ENTRAR
  • No hay productos en el carrito.

Volver a "levantar el proyecto"

Viendo 15 publicaciones - del 1 al 15 (de un total de 18)
  • Autor
    Publicaciones
  • #11118

    Manel Marín Torrent
    Participante

    Hola,

    Realizé la instalación de laravel 5 como indica el video y todo funcionaba bien. En eso que reinicié el equipo y ahora no sé como volver a arrancar el servidor para ver la pantalla de presentacion de laravel en local.

    La que prove és en la carpeta Homestead\HomesteadCursoLaravel5 poser vagrant provision i vagrant up pero no hay manera. Alguna ayuda de que debo hacer?

    Gracias por adelatado y espero resepuesta,

     

    Manel

    #11119

    Cursosdesarrolloweb
    Jefe de claves

    Hola Manel,

    ¿No te arroja ningún error al ejecutar el comando vagrant up?, si te arroja información deberías ponerla aquí para ver cual es el problema.

    Prueba de ejecutar el siguiente comando a ver si funciona.

    vagrant reload –provision

    Si no lo solucionas así te recomiendo volver a realizar los pasos, no tienes que tener ningún problema por reiniciar el equipo si sigues los pasos del curso, aunque ya se sabe, todo depende de muchas cosas.

    Un saludo.

    #11121

    Hice toda mi respuesta en un archivo de word y luego la pegue aqui pero me aparece mal

    #11124

    Mejor te comparto el archivo desde mi dropbox:

     

    https://www.dropbox.com/s/8z8aggasxm3qzqb/Respuesta.docx?dl=0

     

    Esto es solo si necesitas volver a hacer la instalación, parece muy largo, pero en realidad es muy sencillo, no soy muy bueno explicando, pero espero te funcione.

     

    Saludos

    #11126

    Manel Marín Torrent
    Participante

    Hola Pablo y Israel,

    Gracias por vuestra respuesta y teneis toda la razón que no os he dado mucha información.

    Deciros que estoy trabajando con un equipo en windows con las herramientas propuestas por el tutorial. He seguido los pasos del tutorial que aproximadamente son los que explicas Pablo y inicialment funcionaba todo correctamente. En un momento dado he reiniciado el equipo y he ido a la  carpeta C:\Homestead\HomesteadCursoLaravel5 y he puesto el comando vagrant up para arrancar la máquina virtual y el proyecto ha dejado de ver la carpeta del proyecto apareciendo el <span style=”color: #000000; font-family: ‘Times New Roman’; font-size: medium;”>No input file specified.</span>

    También he probador el comando <span style=”color: #444444; font-family: Varela; font-size: 14px;”>vagrant reload –provision</span>  y sale esto donde no veo nada extraño<span style=”font-size: medium; color: #000000; font-family: ‘Times New Roman’;”>.</span>

    ==> homestead-7: Attempting graceful shutdown of VM…

    ==> homestead-7: Checking if box ‘laravel/homestead’ is up to date…

    ==> homestead-7: Clearing any previously set forwarded ports…

    ==> homestead-7: Clearing any previously set network interfaces…

    ==> homestead-7: Preparing network interfaces based on configuration…

    homestead-7: Adapter 1: nat

    homestead-7: Adapter 2: hostonly

    ==> homestead-7: Forwarding ports…

    homestead-7: 80 (guest) => 8000 (host) (adapter 1)

    homestead-7: 443 (guest) => 44300 (host) (adapter 1)

    homestead-7: 3306 (guest) => 33060 (host) (adapter 1)

    homestead-7: 5432 (guest) => 54320 (host) (adapter 1)

    homestead-7: 8025 (guest) => 8025 (host) (adapter 1)

    homestead-7: 27017 (guest) => 27017 (host) (adapter 1)

    homestead-7: 22 (guest) => 2222 (host) (adapter 1)

    ==> homestead-7: Running ‘pre-boot’ VM customizations…

    ==> homestead-7: Booting VM…

    ==> homestead-7: Waiting for machine to boot. This may take a few minutes…

    homestead-7: SSH address: 127.0.0.1:2222

    homestead-7: SSH username: vagrant

    homestead-7: SSH auth method: private key

    homestead-7: Warning: Connection reset. Retrying…

    homestead-7: Warning: Connection aborted. Retrying…

    ==> homestead-7: Machine booted and ready!

    ==> homestead-7: Checking for guest additions in VM…

    ==> homestead-7: Setting hostname…

    ==> homestead-7: Configuring and enabling network interfaces…

    ==> homestead-7: Mounting shared folders…

    homestead-7: /vagrant => C:/Homestead/HomesteadCursoLaravel5

    homestead-7: /home/vagrant/CodeCursoLaravel5/cursolaravel5 => C:/Users/Manel/CodeCursoLaravel5

    ==> homestead-7: Running provisioner: file…

    ==> homestead-7: Running provisioner: shell…

    homestead-7: Running: inline script

    ==> homestead-7: Running provisioner: shell…

    homestead-7: Running: inline script

    ==> homestead-7: Running provisioner: shell…

    homestead-7: Running: inline script

    ==> homestead-7: Running provisioner: shell…

    homestead-7: Running: C:/Users/Manel/AppData/Local/Temp/vagrant-shell20170802-10760-df2w7j.sh

    ==> homestead-7: Running provisioner: shell…

    homestead-7: Running: script: Creating Certificate: curso.laravel

    ==> homestead-7: Running provisioner: shell…

    homestead-7: Running: script: Creating Site: curso.laravel

    ==> homestead-7: Running provisioner: shell…

    homestead-7: Running: script: Checking for old Schedule

    ==> homestead-7: Running provisioner: shell…

    homestead-7: Running: script: Restarting Nginx

    ==> homestead-7: Running provisioner: shell…

    homestead-7: Running: script: Creating MySQL Database: cursolaravel5

    ==> homestead-7: Running provisioner: shell…

    homestead-7: Running: script: Creating Postgres Database: cursolaravel5

    ==> homestead-7: Running provisioner: shell…

    homestead-7: Running: script: Clear Variables

    ==> homestead-7: Running provisioner: shell…

    homestead-7: Running: script: Update Composer

    ==> homestead-7: You are already using composer version 1.4.2 (stable channel).

    ==> homestead-7: Running provisioner: shell…

    homestead-7: Running: C:/Users/Manel/AppData/Local/Temp/vagrant-shell20170802-10760-152iw3h.sh

    A ver si veis algo extraño y me hechais un guante.

    Gracias,

    Manel

    #11128

    Manel Marín Torrent
    Participante

    No sé si podria ser que no hace el mapeo bien porque una de las linias pone

    homestead-7: /home/vagrant/CodeCursoLaravel5/cursolaravel5 => C:/Users/Manel/CodeCursoLaravel5

    pero el proyecto está en homestead-7: C:/Users/Manel/CodeCursoLaravel5/cursolaravel5 quizás pueda ser esto? pero el Homestead.yaml està correcto y luego he hecho el vagrat provision.

    Bien no sé si puede ser esto o no,

     

    Manel

     

    #11131

    Cursosdesarrolloweb
    Jefe de claves

    Hola Manel,

    Revisa bien los paths cómo bien dices, entiendo que has reiniciado de nuevo para ver si se soluciona, y si no es así entonces te recomiendo eliminarlo todo y volver a instalar, estas cosas a veces pasan y es difícil saber cual es el problema.

    Un saludo.

    #11134

    Manel Marín Torrent
    Participante

    Hola Chicos,

    Supongo que algo hago mal. He vuelto a instalar todo y funciona correctamente, pero al reiniciar el equipo i hacer en la carpeta C:\HomesteadCursoLaravel5 el vagrant up no me mapea bien las carpetas y la instalación no sé ve.

    Lo único que veo que hago diferente respecto al tutorial, es el hecho que trabajo en windows y a la hora de editar el archivo Homestead.yaml lo hago en el directorio C:\HomesteadCursoLaravel5 no con el comando sudo nano ~/.homestead/Homestead.yaml como dice el video ya que este comando dice que no existe en gitbash y tampoco existe el directorio C:\Users\Admin\.homestead\Homestead.yaml

    Puede ser esto? Ya veis en algo tan básico y estoy encallado.

    Gracias,

    Manel

    #11135

    Cursosdesarrolloweb
    Jefe de claves

    Hola Manel,

    ¿Es correcta la información si vuelves a abrir el archivo .yaml tras reiniciar?.

    ¿Puedes rehacer la instalación en otro directorio que no sea la raíz de tu disco?, para descartar problemas de permisos.

    ¿Puedes comprobar si tras la reinstalación, cerrando y abriendo una nueva terminal tienes el mismo problema?.

    ¿Estás utilizando una versión estable de VirtualBox?, te recomiendo que te asegures que no sea una versión no estable.

    Hasta el fin de semana no podré hacer pruebas en windows ya que me encuentro fuera y sólo dispongo de un mac.

    Un saludo.

    #11136

    Manel Marín Torrent
    Participante

    Hola Israel,

    Ahora tampoco estoy en casa y probaré todo lo que me dices a la tarde. Lo que si te puedo decir es que el archivo ,yaml mantiene los cambios realizados y el virtualbox que ya uso para otras versiones ubunto lo tengo en la versión 5.1.26 que es estable.

    Tranquilo que no tengo prisa, voy aprendiendo porque ahora estoy un poco más libre.

    Muchas gracias,

    Manel

    #11139

    Manel Marín Torrent
    Participante

    Hola de nuevo,

    He hecho varias pruebas y os explico.

    – Sinó reinicio la máquina, apago el virtual server homestead y el git bash y vuelvo a poner en gitbash poniendo vagrant up o vagrant reload –provision se pierde en la ruta.

    – En cambio si paro y guardo el estado del virtual server homestead, cierro el gitbash y vuelvo a abrirlo poniendo vagrant up, si encuentra la ruta y todo funciona bien.

    Supongo que debe ser algu del virtualbox o quizas esto que os explicava que no puedo usar el sudo nano en gitbash porque además la ruta que hay en el tutorial no aparece en mi máquina.

    Gracias y a ver si me podeis ayudar.

    #11261

    Cursosdesarrolloweb
    Jefe de claves

    Hola Manel,

    Estoy de vuelta, ¿has podido solucionar el problema?, si no es así me pondré con ello para ver si puedo reproducir el error.

    Un saludo.

    #11276

    Manel Marín Torrent
    Participante

    Hola Israel,

    En windows no he conseguido hacerlo. Algo le passa a la ruta o algo no hago bien que se me rompe el enlace y me gustaría saber como hacerlo.

    En ubuntu y sin hometead si me ha salido. A ver si tu tienes un poco de tiempo para descubrir que pasa. Sinó tranquilo puedo ir haciendo.

    Gracias por adelantado,

    Manel

    #11319

    Cursosdesarrolloweb
    Jefe de claves

    Hola Manel,

    He instalado todo desde 0 en windows 8 y windows 10 sin problemas siguiendo los pasos del curso, te paso las versiones que estoy utilizando y mi archivo yaml.

    Vagrant 1.9.7
    VirtualBox 5.1.26
    Laravel 5.4
    Homestead v5.4.0 (cd Homestead && git checkout v5.4.0)

    Cómo puedes ver la instalación la tengo fuera del directorio raíz, simplemente lo hago así para evitar problemas de permisos.

    Sinceramente no entiendo que problema puedes estar teniendo pero a mi me ha funcionado todo perfectamente a la primera, he reiniciado el equipo y todo ok.

    Te dejo esta entrada de mi blog, a lo mejor te soluciona algo, espero que sí.

    Un saludo.

    #11321

    Manel Marín Torrent
    Participante

    Hola Israel,

    Mañana en cuanto pueda lo pruebo y te digo. Quizás sea esto que me explicas de hacer la instalación fuera del directorio raiz. Yo lo estaba haciendo ahí.

    Muchas gracias por tu interès,

    Manel

Viendo 15 publicaciones - del 1 al 15 (de un total de 18)

Debes estar registrado para responder a este debate.

Síguenos en las redes sociales para estar al tanto de los últimas novedades :)

Facebook
Facebook
Google+
Google+
https://www.cursosdesarrolloweb.es/forums/topic/volver-a-levantar-el-proyecto">
Pinterest
Pinterest
top
Cursosdesarrolloweb ©. Todos los derechos reservados.
📢 Inscríbete a cualquier curso por solo 10€ con acceso inmediato y para siempre📢
🌍Los cursos gratuitos son exclusivos de esta plataforma, ÚLTIMOS CURSOS EN 4K🌍
+ +

Login

Create an Account Back to login/register