• ENTRAR
  • No hay productos en el carrito.

Problemas en el tutorial 04devtools del Curso Phalcon 3

Viendo 3 publicaciones - del 1 al 3 (de un total de 3)
  • Autor
    Publicaciones
  • #9832

    Con PHP 5.6.25, Phalcon 3.1.2 y Phalcon DevTools 3.1.2.

    He seguido paso por paso pero no consigo que funcione bien el DevTools.

     

    He detectado que en el archivo config.php la baseUri viene de la seguiente manera:
    ‘baseUri’ => preg_replace(‘/public([\/\\\\])index.php$/’, ”, $_SERVER[“PHP_SELF”]),

    Y me provoca que al clicar por ejemplo en Models->Generate tres veces el link pasa de:
    ‘http://localhost/phalcon3/04devtools/webtools.php’

    a

    ‘http://localhost/phalcon3/04devtools/public/webtools.php/webtools.php/webtools.php/webtools.php?_url=/controllers/generate’

    añadiendome la carpeta public y repitiendo ‘webtools.php/’ por cada click que se haga.

     

    Lo he arreglado “creo” cambiando el baseUri a:

    ‘baseUri’ => ‘/phalcon3/04devtools’

     

     

     

    Separado a este problema que no se si queda arreglado de esta manera, veo que los archivos css y js que se encuentra en /public/css/ y /public/js/, en el código fuente de la página cargada los href del <head> quedan de la siguiente manera:

    <link rel=”shortcut icon” href=”/favicon.ico?v=3.1.2″>
    <script type=”text/javascript” src=”/js/webtools-ie.js?v=3.1.2″></script>
    <link rel”stylesheet” type=”text/css” href=”/css/webtools.css?v=3.1.2″>

    Más este archivo js de debajo del footer:

    <script type=”text/javascript” src=”/js/webtools.js?v=3.1.2″>

     

    Lógicamente el href se debe substituir por :  css/webtools.css?v=3.1.2 borrando la primera “/” y así imagino que debería ser en todos los links.

     

    El problema és que no se donde realizar este cambio ni de qué manera para que no provoque futuros errores en otros proyectos.

    #9834

    ‘baseUri’ => ‘/phalcon3/04devtools/’  <- añadida una linia que deja doble barra en la zona webtools pero luego el scaffold funciona bien. Si lo dejaba como la anterior el scaffold en la sección de search por ejemplo el url resultante era de la siguiente forma:

    http://localhost/phalcon3/04devtoolsposts/search donde 04devtools y posts quedaban enganchados.

    #9837

    Cursosdesarrolloweb
    Jefe de claves

    Hola Ricard,

    Perdona pero no entiendo cual es el problema que tienes ni si lo has podido resolver.

    Recuerda que para publicar código en el foro debes crear un gist, aquí tienes más información.

Viendo 3 publicaciones - del 1 al 3 (de un total de 3)

Debes estar registrado para responder a este debate.

Síguenos en las redes sociales para estar al tanto de los últimas novedades :)

Facebook
Facebook
Google+
Google+
https://www.cursosdesarrolloweb.es/forums/topic/problemas-en-el-tutorial-04devtools-del-curso-phalcon-3">
Pinterest
Pinterest
top
Cursosdesarrolloweb ©. Todos los derechos reservados.
🔓Inscríbete a cualquier curso por 9€ y accede a todos los cursos gratuitos para siempre🔓
🌍Los cursos gratuitos son exclusivos de esta plataforma, ÚLTIMOS CURSOS EN 4K🌍
+ +

Login

Create an Account Back to login/register