• ENTRAR
  • No hay productos en el carrito.

Problema con Php-DI en el segundo paso (segundo video)

Viendo 4 publicaciones - del 1 al 4 (de un total de 4)
  • Autor
    Publicaciones
  • #11550

    juanjolrz
    Participante

    Hola Israel, tengo un problema con la inyeccion de dependencias. Sólo consigo un 404 NOR FOUND, es decir no me trabajan las rutas… el código está exactamente igual porque he seguido el procedimiento paso a paso (y más de una vez). La única diferencia es que trabajo con xampp y no levante ningun otro servidor en 9000 y no se si ese es el problema.

    El FastRoute me funciono en su momento indicando la ruta absoluta de los ficheros, pero ahora que en este video se configura utilizando el namespace Blog pues no funciona… le he dado mil vueltas antes de preguntar pero estoy atascado.

    Gracias de antemano

    #11562

    Cursosdesarrolloweb
    Jefe de claves

    Hola Juanjo,

    Si no necesitas por algún motivo en concreto utilizar Xampp te recomiendo que sigas utilizando el comando php -S localhost:9000, aunque puedes utilizar el puerto que necesites.

    Piensa que este curso es para aprender a trabajar de forma correcta con Php, personalmente recomiendo seguir con este curso para sacarle más provecho y finalmente decantarse por algún framework, Laravel, Codeigniter o Phalcon son algunos de los disponibles en la plataforma.

    Un saludo.

    #11563

    juanjolrz
    Participante

    Entiendo lo que me dices Israel y probaré a trabajar con ese comando… lo que no entiendo y no me queda claro es si ese es el problema; es decir si no funciona el puerto por defecto en xampp al utilizar los métodos de fastroute mediante el namespace (con las rutas absolutas de vídeos anteriores funcionó sin problema)… crees que ese es el problema?

    Gracias de antemano

    #11564

    Cursosdesarrolloweb
    Jefe de claves

    Hola Juanjo,

    El problema de porque no funciona la aplicación con Xampp no es por fastroute, sino porque en ningún momento se ha configurado el servidor, sea apache o nginx, en este punto no me preocupan esos temas ya que cómo te he comentado anteriormente quedan solucionados al pasar a trabajar con frameworks que es el camino recomendado para el desarrollo de aplicaciones web con php.

    Referente al puerto, da igual que utilices el 9000 o el 5000, es lo mismo, mientras esté disponible, es decir, no esté en uso por otra aplicación no tendrás problemas.

    Un saludo.

Viendo 4 publicaciones - del 1 al 4 (de un total de 4)

Debes estar registrado para responder a este debate.

Síguenos en las redes sociales para estar al tanto de los últimas novedades :)

Facebook
Facebook
Google+
Google+
https://www.cursosdesarrolloweb.es/forums/topic/problema-con-php-di-en-el-segundo-paso-segundo-video">
Pinterest
Pinterest
top
Cursosdesarrolloweb ©. Todos los derechos reservados.
📢 Inscríbete a cualquier curso por solo 10€ con acceso inmediato y para siempre📢
🌍Los cursos gratuitos son exclusivos de esta plataforma, ÚLTIMOS CURSOS EN 4K🌍
+ +

Login

Create an Account Back to login/register