• ENTRAR
  • No hay productos en el carrito.

Inconvenientes con el funcionamiento de MEDIA_CAPTURE en un movil real

Viendo 4 publicaciones - del 1 al 4 (de un total de 4)
  • Autor
    Publicaciones
  • #14800

    francoguns16
    Participante

    Saludos cordiales,

    Tengo una duda, en la aplicacion de media_capture me funciona perfectamente cuando utilizo el emulador de mi maquina probandolo tanto con video como con imagen, pero al pasar el archivo APK a mi celular el funcionamiento no es el mismo.

    Inconveniente: La aplicacion se queda como en un bucle infinito mostrando el mensaje: “Subiendo video …”, a pesar de esto reviso en el servidor y si se ha recibido el video o la imagen, el otro inconveniente es no suben completos. Por ejemplo grabo un video de 5 segundos y solo aparece un video de 1 segundo, lo mismo con la imagen solo muestra la parte superior de la imagen y lo demas esta en negro.

    A que crees que pueda deberse este comportamiento?

    Gracias.

    #14801

    Cursosdesarrolloweb
    Jefe de claves

    Buenos días,

    ¿El servidor que utilizas para ambos casos es el mismo?, si la APP es la misma, y funciona con el emulador, no debe dejar de funcionar cuando la tienes instalada, más aún cuando el archivo sí sube.

    Quedo atento.
    Saludos.

    #14803

    francoguns16
    Participante

    Si, es el mismo servidor que estoy utilizando para ambas aplicaciones, estoy utilizando el servidor que brindaste en el curso.

    Entonces a que puede deberse el problema, tienes algun correo donde puedo enviarte el APK para mostrartelo?

    O que solucion le puedo dar, o como buscar posibles problemas?

    Gracias.

    #14804

    Cursosdesarrolloweb
    Jefe de claves

    Buenas,

    Es extraño, hago uso de un código similar con Node.js y AWS sin problemas desde hace mucho tiempo, si el dispositivo no da error en la subida, pero este no sube correctamente, y siempre es utilizando el mismo archivo, no sé a qué puede deberse, te recomiendo que revises a conciencia el método this.cameraProvider.sendVideo(data[0]) ya que obviamente ahí es donde está el problema, trata de capturar todos los posibles errores y hacer debug ahí, yo no voy a hacer nada distinto.

    Saludos.

Viendo 4 publicaciones - del 1 al 4 (de un total de 4)

Debes estar registrado para responder a este debate.

Síguenos en las redes sociales para estar al tanto de los últimas novedades :)

Facebook
Facebook
Google+
Google+
https://www.cursosdesarrolloweb.es/forums/topic/inconvenientes-con-el-funcionamiento-de-media_capture-en-un-movil-real">
Pinterest
Pinterest
top
Cursosdesarrolloweb ©. Todos los derechos reservados.
📢 Inscríbete a cualquier curso por solo 10€ con acceso inmediato y para siempre📢
🌍Los cursos gratuitos son exclusivos de esta plataforma, ÚLTIMOS CURSOS EN 4K🌍
+ +

Login

Create an Account Back to login/register